Extend Your Reach with Plugable’s USB 3.0 Powered Extension Cables

Plugable’s new USB 3.0 cables maximize compatibility over long distances

The new Plugable USB3-5M and Plugable USB3-10M make extending USB 3.0 connectivity over longer distances viable with several major improvements:

  • We upgraded these cables to USB 3.0 specifications to meet the performance and power requirements of complex USB 3.0 devices.
  • We include an AC power adapter with each USB 3.0 extension cable to comply with USB 3.0’s higher 900mA power requirements
  • We use the best available wire (gauge and quality) to maintain signal integrity over long runs.

These upgrades are critical to supporting these long cable lengths with the high throughput and high power expected by USB 3.0 devices.

For example, a very happy Plugable team member discovered that these USB 3.0 extension cables work great to extend his new Oculus Rift VR equipment at home! The Oculus Rift makes full use of USB 3.0 and needs this kind of solution to work well.

These cables are a great choice for extending the reach of complex USB 3.0 devices like gaming peripherals, DisplayLink devices, and webcams. Our USB 2.0 extension cables (Plugable USB2-5M and Plugable USB2-10M) still make a great choice for simpler USB devices.

See the links below for additional compatibility information with our new USB 3.0 extension cables:
www.plugable.com/products/USB3-5M
www.plugable.com/products/USB3-10M

Any questions? Just comment below or email support@plugable.com and we’ll be happy to help.

Where to Buy

We have a Problem with JSON here:
Either we got no JSON from the API. Or the basenode-parameter is not ok.
Switch on the Debugmode of the Plugin!
Switch to gutenberg-Blocks!
There the JSON Content Importer Block gives an easier way to use the JSON-APIs.
Or: Switch on the Debugmode by adding "debugmode=10" in the Shortcode.

If all is without success: Open ticket at wordpress.org please


We have a Problem with JSON here:
Either we got no JSON from the API. Or the basenode-parameter is not ok.
Switch on the Debugmode of the Plugin!
Switch to gutenberg-Blocks!
There the JSON Content Importer Block gives an easier way to use the JSON-APIs.
Or: Switch on the Debugmode by adding "debugmode=10" in the Shortcode.

If all is without success: Open ticket at wordpress.org please


Leave A Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.