DisplayLink and some other USB and wireless displays no longer work on macOS 10.13.4 Learn More.

macOS High Sierra 10.13.4 Beta compatibility with DisplayLink devices

Update 3/29/2018 – We have updated our recommendations for changing for the system update options within system preferences. Please see the details below

As Apple improves and releases updates to their operating system macOS, they release public beta versions so that those who wish to do so can test new features and fixes and report any problems should they arise.

With the recent public beta release of the next version of macOS version 10.13.4 beta, changes made by Apple have unfortunately broken support for USB video adapters and/or docking stations based on DisplayLink technology.

The USB docking stations that Plugable offers and supports within macOS such as our UD-ULTCDL and UD-ULTC4K are based on DisplayLink technology, so as a result if any of our customers using these products update to the public beta of 10.13.4 the displays attached to their devices will stop working.

DisplayLink (the separate company from Plugable that makes the chips in our DisplayLink-based products and writes the driver) are aware of the issue and are working on a fix. The issue is being tracked publicly in their support forum here -> https://www.displaylink.org/forum/showthread.php?t=65890

DisplayLink has also raised the issue with Apple directly (Bug ID# 37385102) but as of today there is no fix or workaround for the behavior. Plugable recommends that any of our customers not install the 10.13.4 beta if they are using a DisplayLink-based video adapter or docking station.

Apple does not publish a specific date for when the final non-beta release will be made available, but as a precaution moving forward we would recommend that any of our potentially affected customers temporarily remove the check mark for both the ‘Download newly available updates in the background’ and ‘Install macOS Updates’ options within the App Store preferences application available within System Preferences. This will help ensure that if a fix is not found prior to the final public release of 10.13.4, their systems will remain on the 10.13.3 version which does work properly with DisplayLink.

As we have updates for this issue we will update the top of this post to reflect them. If any of our customers have any additional questions regarding this issue, please reach out to us directly via support@plugable.com and we will be happy to help.

4 comments on “macOS High Sierra 10.13.4 Beta compatibility with DisplayLink devices”

  1. Derek Reply

    Hi Michael, thanks for your post. I sent you a message last Thursday with some questions and just sent you another as well. If you could please reply, we can continue troubleshooting. Thanks!

  2. jalil Reply

    hello i use high sierra 10.13.5 and its not work. did you have some drivers or something to help to fix this?
    thanks
    regards

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.