MultiSeat Terminal Software

Software for MultiSeat Terminals

This software is needed for the Plugable UT-1. This product is discontinued, but is mentioned among our legacy products  .

Applicable Products

For Windows Multipoint Server (WMS) 2011 and 2012, the OSBase driver is the only supported option.

WMS 2012 is recommended over WMS 2011 due to noticeable improvements in performance made possible by WMS 2012. Installation instructions are also available on the OSBase site

Platform Version and Download Notes Date
Windows Multipoint Server 2012 Download
Windows Multipoint Server 2011 Download
Fedora or Userful Linux
Fedora 18

Fedora 18 is a largely plug-and-play experience, and is a great option for users with Linux experience. Performance varies by hardware, but a non-compositing desktop environment such as Gnome-Fallback, XFCE or LXDE is recommended for the smoothest experience. Experienced Linux users familiar with configuring desktop managers should have little more to do than add users for each terminal.

Userful Linux

Userful Linux is compatible with both Plugable’s multiseat terminals, however since Userful is a paid distribution customers should seek support from Userful directly.
Page ID 68340842661